What’s Vulnerable › Vulnerabilities

CVE-2022-43569: Persistent Cross-Site Scripting via a Data Model object name in Splunk Enterprise

Description

In Splunk Enterprise versions below 8.1.12, 8.2.9, and 9.0.2, an authenticated user can inject and store arbitrary scripts that can lead to persistent cross-site scripting (XSS) in the object name of a Data Model.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 8.1.12, 8.2.9, 9.0.2; Splunk Cloud Platform 9.0.2209. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-43569 or the next vulnerability affects your stack