What’s Vulnerable › Vulnerabilities
CVE-2022-43654: NETGEAR CAX30S SSO Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-78
Description
NETGEAR CAX30S SSO Command Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR CAX30S routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of the token parameter provided to the sso.php endpoint. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-18227.
Affected products
- NETGEAR CAX30: before 2.1.3.10 — fixed in 2.1.3.10
- NETGEAR Cax30S Firmware: before 2.1.3.10 — fixed in 2.1.3.10
How to fix
Upgrade to a fixed version: NETGEAR CAX30 2.1.3.10; NETGEAR Cax30S Firmware 2.1.3.10. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065527/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Cable-Modem-Routers-PSV-2022-0208
- https://www.zerodayinitiative.com/advisories/ZDI-23-214/
- https://kb.netgear.com/000065527/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Cable-Modem-Routers-PSV-2022-0208
- https://www.zerodayinitiative.com/advisories/ZDI-23-214/
Get alerted when CVE-2022-43654 or the next vulnerability affects your stack