What’s Vulnerable › Vulnerabilities
CVE-2022-43706
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Web UI of StackStorm versions prior to 3.8.0 allowed logged in users with write access to pack rules to inject arbitrary script or HTML that may be executed in Web UI for other logged in users.
Affected products
- Stackstorm: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: Stackstorm 3.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43706 or the next vulnerability affects your stack