What’s Vulnerable › Vulnerabilities
CVE-2022-43755: Rancher: Non-random authentication token
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-331
Description
A Insufficient Entropy vulnerability in SUSE Rancher allows attackers that gained knowledge of the cattle-token to continue abusing this even after the token was renewed. This issue affects: SUSE Rancher Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.
Affected products
- SUSE Rancher: from 2.6.0 before 2.6.10; from 2.7.0 before 2.7.1 — fixed in 2.6.10, 2.7.1
How to fix
Upgrade to a fixed version: SUSE Rancher 2.6.10, 2.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43755 or the next vulnerability affects your stack