What’s Vulnerable › Vulnerabilities
CVE-2022-43756: Rancher/Wrangler: Denial of service when processing Git credentials
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-74
Description
A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.
Affected products
- SUSE Wrangler: before 0.7.4; from 0.8.0 before 0.8.5; 1.0.0 — fixed in 0.7.4, 0.8.5
How to fix
Upgrade to a fixed version: SUSE Wrangler 0.7.4, 0.8.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43756 or the next vulnerability affects your stack