What’s Vulnerable › Vulnerabilities
CVE-2022-43757: Rancher: Exposure of sensitive fields
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-312
Description
A Cleartext Storage of Sensitive Information vulnerability in SUSE Rancher allows users on managed clusters to gain access to credentials. The impact depends on the credentials exposed This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.
Affected products
- SUSE Rancher: from 2.5.0 before 2.5.17; from 2.6.0 before 2.6.10; from 2.7.0 before 2.7.1 — fixed in 2.5.17, 2.6.10, 2.7.1
How to fix
Upgrade to a fixed version: SUSE Rancher 2.5.17, 2.6.10, 2.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43757 or the next vulnerability affects your stack