What’s Vulnerable › Vulnerabilities
CVE-2022-43758: Rancher: Command injection in Git package
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-78
Description
A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in SUSE Rancher allows code execution for user with the ability to add an untrusted Helm catalog or modifying the URL configuration used to download KDM (only admin users by default) This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10; Rancher versions prior to 2.7.1.
Affected products
- SUSE Rancher: from 2.5.0 before 2.5.17; from 2.6.0 before 2.6.10; from 2.7.0 before 2.7.1 — fixed in 2.5.17, 2.6.10, 2.7.1
How to fix
Upgrade to a fixed version: SUSE Rancher 2.5.17, 2.6.10, 2.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43758 or the next vulnerability affects your stack