What’s Vulnerable › Vulnerabilities
CVE-2022-43759: Rancher: Privilege escalation via promoted roles
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-269
Description
A Improper Privilege Management vulnerability in SUSE Rancher, allows users with access to the escalate verb on PRTBs to escalate permissions for any -promoted resource in any cluster. This issue affects: SUSE Rancher Rancher versions prior to 2.5.17; Rancher versions prior to 2.6.10.
Affected products
- SUSE Rancher: from 2.5.0 before 2.5.17; from 2.6.0 before 2.6.10 — fixed in 2.5.17, 2.6.10
How to fix
Upgrade to a fixed version: SUSE Rancher 2.5.17, 2.6.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43759 or the next vulnerability affects your stack