What’s Vulnerable › Vulnerabilities

CVE-2022-43760

Description

An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SUSE Rancher allows users in some higher-privileged groups to to inject code that is executed within another user's browser, allowing the attacker to steal sensitive information, manipulate web content, or perform other malicious activities on behalf of the victims. This could result in a user with write access to the affected areas being able to act on behalf of an administrator, once an administrator opens the affected web page. This issue affects Rancher: from >= 2.6.0 before < 2.6.13, from >= 2.7.0 before < 2.7.4.

Affected products

How to fix

Upgrade to a fixed version: SUSE Rancher 2.6.13, 2.7.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-43760 or the next vulnerability affects your stack