What’s Vulnerable › Vulnerabilities

CVE-2022-43766: Apache IoTDB prior to 0.13.3 allows DoS

Description

Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.

Affected products

References

Get alerted when CVE-2022-43766 or the next vulnerability affects your stack