What’s Vulnerable › Vulnerabilities
CVE-2022-43776
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-918
Description
The url parameter of the /api/geojson endpoint in Metabase versions <44.5 can be used to perform Server Side Request Forgery attacks. Previously implemented blacklists could be circumvented by leveraging 301 and 302 redirects.
Affected products
- metabase: before 0.44.5 — fixed in 0.44.5
How to fix
Upgrade to a fixed version: metabase 0.44.5. Check the vendor advisory for mitigations.
References
- https://www.tenable.com/security/research/tra-2022-34
- https://www.tenable.com/security/research/tra-2022-34
Get alerted when CVE-2022-43776 or the next vulnerability affects your stack