What’s Vulnerable › Vulnerabilities
CVE-2022-4379
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability was found in __nfs42_ssc_open() in fs/nfs/nfs4file.c in the Linux kernel. This flaw allows an attacker to conduct a remote denial
Affected products
- Fedoraproject Fedora: 36, 37
- Linux kernel: from 5.6 before 5.10.177; from 5.11 before 5.15.105; from 5.16 before 6.1.3 — fixed in 5.10.177, 5.15.105, 6.1.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.177, 5.15.105, 6.1.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=75333d48f92256a0dec91dbf07835e804fc411c0
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=aeba12b26c79fc35e07e511f692a8907037d95da
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LECFVUHKIRBV5JJBE3KQCLGKNYJPBRCN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RAVD6JIILAVSRHZ4VXSV3RAAGUXKVXZA/
- https://seclists.org/oss-sec/2022/q4/185
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=75333d48f92256a0dec91dbf07835e804fc411c0
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=aeba12b26c79fc35e07e511f692a8907037d95da
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LECFVUHKIRBV5JJBE3KQCLGKNYJPBRCN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RAVD6JIILAVSRHZ4VXSV3RAAGUXKVXZA/
- https://seclists.org/oss-sec/2022/q4/185
Get alerted when CVE-2022-4379 or the next vulnerability affects your stack