What’s Vulnerable › Vulnerabilities
CVE-2022-43902: IBM MQ denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-10 · updated 2026-06-17
Description
IBM MQ 9.2 CD, 9.2 LTS, 9.3 CD, and 9.3 LTS is vulnerable to a denial of service attack caused by specially crafted PCF or MQSC messages. IBM X-Force ID: 240832.
Affected products
- IBM MQ Appliance: from 9.2.0.0 before 9.2.0.8; from 9.2.0.0 before 9.2.5; 9.2.5, 9.2.5-cumulative_security_update_01, 9.2.5-cumulative_security_update_02, 9.2.5-cumulative_security_update_03, 9.3.0.0, 9.3.1 — fixed in 9.2.0.8, 9.2.5
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.2.0.8, 9.2.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/240832
- https://www.ibm.com/support/pages/node/6890643
- https://exchange.xforce.ibmcloud.com/vulnerabilities/240832
- https://www.ibm.com/support/pages/node/6890643
Get alerted when CVE-2022-43902 or the next vulnerability affects your stack