What’s Vulnerable › Vulnerabilities
CVE-2022-43916: IBM App Connect Enterprise Certified Container improper communications restriction
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-923
Description
IBM App Connect Enterprise Certified Container 7.1, 7.2, 8.0, 8.1, 8.2, 9.0, 9.1, 9.2, 10.0, 10.1, 11.0, 11.1, 11.2, 11.3, 11.4, 11.5, 11.6, 12.0, 12.1, 12.2, 12.3, 12.4, 12.5, 12.6, and 12.7 Pods do not restrict network egress for Pods that are used for internal infrastructure.
Affected products
- IBM App Connect Enterprise Certified Container: from 7.1 before 12.8 — fixed in 12.8
How to fix
Upgrade to a fixed version: IBM App Connect Enterprise Certified Container 12.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43916 or the next vulnerability affects your stack