What’s Vulnerable › Vulnerabilities
CVE-2022-43919: IBM MQ denial of service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-05 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM MQ 9.2 CD, 9.2 LTS, 9.3 CD, and 9.3 LTS could allow an authenticated attacker with authorization to craft messages to cause a denial of service. IBM X-Force ID: 241354.
Affected products
- IBM MQ Appliance: from 9.2.0.0 before 9.2.0.10; from 9.2.0.0 before 9.2.5.7; from 9.3.0.0 before 9.3.0.5; from 9.3.0.0 before 9.3.2 — fixed in 9.2.0.10, 9.2.5.7, 9.3.0.5, 9.3.2
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.2.0.10, 9.2.5.7, 9.3.0.5, 9.3.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/241354
- https://www.ibm.com/support/pages/node/6986559
- https://exchange.xforce.ibmcloud.com/vulnerabilities/241354
- https://www.ibm.com/support/pages/node/6986559
Get alerted when CVE-2022-43919 or the next vulnerability affects your stack