What’s Vulnerable › Vulnerabilities
CVE-2022-4393: ImageLinks Interactive Image Builder for WordPress <= 1.5.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The ImageLinks Interactive Image Builder for WordPress plugin through 1.5.3 does not sanitise and escape some of its settings, which could allow users such as contributor+ to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- ImageLinks Interactive Image Builder for WordPress: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: ImageLinks Interactive Image Builder for WordPress 1.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0bd4f370-f9f8-43ee-8f20-96e899a1efb5
- https://wpscan.com/vulnerability/0bd4f370-f9f8-43ee-8f20-96e899a1efb5
Get alerted when CVE-2022-4393 or the next vulnerability affects your stack