What’s Vulnerable › Vulnerabilities
CVE-2022-4395: Membership For WooCommerce < 2.1.7 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The Membership For WooCommerce WordPress plugin before 2.1.7 does not validate uploaded files, which could allow unauthenticated users to upload arbitrary files, such as malicious PHP code, and achieve RCE.
Affected products
- WP Swings Membership For WooCommerce: before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: WP Swings Membership For WooCommerce 2.1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/80407ac4-8ce3-4df7-9c41-007b69045c40
- https://packetstormsecurity.com/files/177934/WordPress-Membership-For-WooCommerce-Shell-Upload.html
- https://wpscan.com/vulnerability/80407ac4-8ce3-4df7-9c41-007b69045c40
- https://www.exploit-db.com/exploits/51959
Get alerted when CVE-2022-4395 or the next vulnerability affects your stack