What’s Vulnerable › Vulnerabilities
CVE-2022-43952
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
An improper neutralization of input during web page generation ('Cross-site Scripting') vulnerability [CWE-79] in FortiADC version 7.1.1 and below, version 7.0.3 and below, version 6.2.5 and below may allow an authenticated attacker to perform a cross-site scripting attack via crafted HTTP requests.
Affected products
- Fortinet FortiADC: from 6.2.0 before 6.2.6; from 7.0.0 before 7.0.4; from 7.1.0 before 7.1.2 — fixed in 6.2.6, 7.0.4, 7.1.2
How to fix
Upgrade to a fixed version: Fortinet FortiADC 6.2.6, 7.0.4, 7.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43952 or the next vulnerability affects your stack