What’s Vulnerable › Vulnerabilities
CVE-2022-43971: Arbitrary code execution in Linksys WUMC710
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-09 · updated 2026-06-17
- Weakness: CWE-78
Description
An arbitrary code exection vulnerability exists in Linksys WUMC710 Wireless-AC Universal Media Connector with firmware <= 1.0.02 (build3). The do_setNTP function within the httpd binary uses unvalidated user input in the construction of a system command. An authenticated attacker with administrator privileges can leverage this vulnerability over the network via a malicious GET or POST request to /setNTP.cgi to execute arbitrary commands on the underlying Linux operating system as root.
Affected products
- Linksys WUMC710 Wireless-AC Universal Media Connector: before 1.0.02; 1.0.02, 1.0.02-build3 — fixed in 1.0.02
How to fix
Upgrade to a fixed version: Linksys WUMC710 Wireless-AC Universal Media Connector 1.0.02. Check the vendor advisory for mitigations.
References
- https://youtu.be/73-1lhvJPNg
- https://youtu.be/RfWVYCUBNZ0
- https://youtu.be/TeWAmZaKQ_w
- https://youtu.be/73-1lhvJPNg
- https://youtu.be/RfWVYCUBNZ0
- https://youtu.be/TeWAmZaKQ_w
Get alerted when CVE-2022-43971 or the next vulnerability affects your stack