What’s Vulnerable › Vulnerabilities

CVE-2022-43974

Description

MatrixSSL 4.0.4 through 4.5.1 has an integer overflow in matrixSslDecodeTls13. A remote attacker might be able to send a crafted TLS Message to cause a buffer overflow and achieve remote code execution. This is fixed in 4.6.0.

Affected products

How to fix

Upgrade to a fixed version: Inside Secure MatrixSSL 4.6.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-43974 or the next vulnerability affects your stack