What’s Vulnerable › Vulnerabilities
CVE-2022-43982: Apache Airflow prior to 2.4.2 allows reflected XSS via Origin Query Argument in URL
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-02 · updated 2026-06-17
- Weakness: CWE-79
Description
In Apache Airflow versions prior to 2.4.2, the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument.
Affected products
- Apache Airflow: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/27143
- https://lists.apache.org/thread/vqnvdrfsw9z7v7c46qh3psjgr7wy959l
- https://github.com/apache/airflow/pull/27143
- https://lists.apache.org/thread/vqnvdrfsw9z7v7c46qh3psjgr7wy959l
Get alerted when CVE-2022-43982 or the next vulnerability affects your stack