What’s Vulnerable › Vulnerabilities
CVE-2022-43985: Apache Airflow prior to 2.4.2 has an open redirect
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-02 · updated 2026-06-17
- Weakness: CWE-601
Description
In Apache Airflow versions prior to 2.4.2, there was an open redirect in the webserver's `/confirm` endpoint.
Affected products
- Apache Airflow: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/27143
- https://lists.apache.org/thread/m13y9s5kw92fw9l8j4qd85h0txp4kfcq
- https://github.com/apache/airflow/pull/27143
- https://lists.apache.org/thread/m13y9s5kw92fw9l8j4qd85h0txp4kfcq
Get alerted when CVE-2022-43985 or the next vulnerability affects your stack