What’s Vulnerable › Vulnerabilities
CVE-2022-43995
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-02 · updated 2026-06-17
- Weakness: CWE-125
Description
Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.
Affected products
- sudo: from 1.8.0 before 1.9.12; 1.9.12 — fixed in 1.9.12
How to fix
Upgrade to a fixed version: sudo 1.9.12. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2139911
- https://github.com/sudo-project/sudo/commit/bd209b9f16fcd1270c13db27ae3329c677d48050
- https://news.ycombinator.com/item?id=33465707
- https://security.gentoo.org/glsa/202211-08
- https://www.sudo.ws/security/advisories/
- https://bugzilla.redhat.com/show_bug.cgi?id=2139911
- https://github.com/sudo-project/sudo/commit/bd209b9f16fcd1270c13db27ae3329c677d48050
- https://news.ycombinator.com/item?id=33465707
- https://security.gentoo.org/glsa/202211-08
- https://www.sudo.ws/security/advisories/
Get alerted when CVE-2022-43995 or the next vulnerability affects your stack