What’s Vulnerable › Vulnerabilities
CVE-2022-4427: SQL Injection via OTRS Search API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-19 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in OTRS AG OTRS, OTRS AG ((OTRS)) Community Edition allows SQL Injection via TicketSearch Webservice This issue affects OTRS: from 7.0.1 before 7.0.40 Patch 1, from 8.0.1 before 8.0.28 Patch 1; ((OTRS)) Community Edition: from 6.0.1 through 6.0.34.
Affected products
- OTRS AG OTRS: from 6.0.1 through 6.0.34; from 7.0.1 before 7.0.40; from 8.0.1 before 8.0.28; 7.0.40, 8.0.28 — fixed in 7.0.40, 8.0.28
How to fix
Upgrade to a fixed version: OTRS AG OTRS 7.0.40, 8.0.28. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/08/msg00040.html
- https://otrs.com/release-notes/otrs-security-advisory-2022-15/
- https://lists.debian.org/debian-lts-announce/2023/08/msg00040.html
- https://otrs.com/release-notes/otrs-security-advisory-2022-15/
Get alerted when CVE-2022-4427 or the next vulnerability affects your stack