What’s Vulnerable › Vulnerabilities
CVE-2022-4431: WOOCS < 1.3.9.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The WOOCS WordPress plugin before 1.3.9.4 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- realmag777 FOX – Currency Switcher Professional for WooCommerce: before 1.3.9.4 — fixed in 1.3.9.4
How to fix
Upgrade to a fixed version: realmag777 FOX – Currency Switcher Professional for WooCommerce 1.3.9.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/860b882b-983c-44b5-8c09-b6890df8a0da
- https://wpscan.com/vulnerability/c7d12fd4-7346-4727-9f6c-7e7e5524a932
- https://wpscan.com/vulnerability/860b882b-983c-44b5-8c09-b6890df8a0da
- https://wpscan.com/vulnerability/c7d12fd4-7346-4727-9f6c-7e7e5524a932
Get alerted when CVE-2022-4431 or the next vulnerability affects your stack