What’s Vulnerable › Vulnerabilities
CVE-2022-44370
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-787
Description
NASM v2.16 was discovered to contain a heap buffer overflow in the component quote_for_pmake() asm/nasm.c:856
Affected products
- NASM Netwide Assember: before 2.16; 2.16-rc1 — fixed in 2.16
How to fix
Upgrade to a fixed version: NASM Netwide Assember 2.16. Check the vendor advisory for mitigations.
References
- https://bugzilla.nasm.us/show_bug.cgi?id=3392815
- https://security.gentoo.org/glsa/202312-09
- https://bugzilla.nasm.us/show_bug.cgi?id=3392815
- https://security.gentoo.org/glsa/202312-09
Get alerted when CVE-2022-44370 or the next vulnerability affects your stack