What’s Vulnerable › Vulnerabilities
CVE-2022-4448: GiveWP < 2.24.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The GiveWP WordPress plugin before 2.24.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- stellarwp GiveWP – Donation Plugin and Fundraising Platform: before 2.24.0 — fixed in 2.24.0
How to fix
Upgrade to a fixed version: stellarwp GiveWP – Donation Plugin and Fundraising Platform 2.24.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ce467a2e-081e-4a6c-bfa4-29e4447ebd3b
- https://wpscan.com/vulnerability/ce467a2e-081e-4a6c-bfa4-29e4447ebd3b
Get alerted when CVE-2022-4448 or the next vulnerability affects your stack