What’s Vulnerable › Vulnerabilities
CVE-2022-4451: Sassy Social Share < 3.3.45 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Social Sharing WordPress plugin before 3.3.45 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- heateor Social Sharing Plugin – Sassy Social Share: before 3.3.45 — fixed in 3.3.45
How to fix
Upgrade to a fixed version: heateor Social Sharing Plugin – Sassy Social Share 3.3.45. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a28f52a4-fd57-4f46-8983-f34c71ec88d5
- https://wpscan.com/vulnerability/a28f52a4-fd57-4f46-8983-f34c71ec88d5
Get alerted when CVE-2022-4451 or the next vulnerability affects your stack