What’s Vulnerable › Vulnerabilities
CVE-2022-44515: Acrobat Reader | Out-of-bounds Read (CWE-125)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-125
Description
Acrobat Reader DC version 22.001.20085 (and earlier), 20.005.3031x (and earlier) and 17.012.30205 (and earlier) are affected by an out-of-bounds read vulnerability when parsing a crafted file, which could result in a read past the end of an allocated memory structure. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 17.011.30059 before 17.012.30229; from 20.001.30002 before 20.005.30334; from 17.011.30059 before 17.012.30227; from 20.001.30002 before 20.005.30331 — fixed in 17.012.30227, 17.012.30229, 20.005.30331, 20.005.30334
- Adobe Acrobat DC: from 22.001.20085 before 22.001.20117; from 22.001.20085 before 22.001.20112 — fixed in 22.001.20112, 22.001.20117
- Adobe Acrobat Reader: from 17.011.30059 before 17.012.30229; from 20.001.30002 before 20.005.30334; from 17.011.30059 before 17.012.30227; from 20.001.30002 before 20.005.30331 — fixed in 17.012.30227, 17.012.30229, 20.005.30331, 20.005.30334
- Adobe Acrobat Reader: from 22.001.20085 before 22.001.20117; from 22.001.20085 before 22.001.20112 — fixed in 22.001.20112, 22.001.20117
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 17.012.30227, 17.012.30229, 20.005.30331, 20.005.30334; Adobe Acrobat DC 22.001.20112, 22.001.20117; Adobe Acrobat Reader 17.012.30227, 17.012.30229, 20.005.30331, 20.005.30334; Adobe Acrobat Reader 22.001.20112, 22.001.20117. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-44515 or the next vulnerability affects your stack