What’s Vulnerable › Vulnerabilities

CVE-2022-44516: Acrobat Reader | Out-of-bounds Read (CWE-125)

Description

Acrobat Reader DC version 22.001.20085 (and earlier), 20.005.3031x (and earlier) and 17.012.30205 (and earlier) are affected by an out-of-bounds read vulnerability when parsing a crafted file, which could result in a read past the end of an allocated memory structure. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Acrobat for Edge 17.012.30227, 17.012.30229, 20.005.30331, 20.005.30334; Adobe Acrobat DC 22.001.20112, 22.001.20117; Adobe Acrobat Reader 17.012.30227, 17.012.30229, 20.005.30331, 20.005.30334; Adobe Acrobat Reader 22.001.20112, 22.001.20117. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-44516 or the next vulnerability affects your stack