What’s Vulnerable › Vulnerabilities
CVE-2022-44542
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-01 · updated 2026-06-17
- Weakness: CWE-502
Description
lesspipe before 2.06 allows attackers to execute code via Perl Storable (pst) files, because of deserialized object destructor execution via a key/value pair in a hash.
Affected products
- Lesspipe Project Lesspipe: before 2.06 — fixed in 2.06
How to fix
Upgrade to a fixed version: Lesspipe Project Lesspipe 2.06. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/865631
- https://github.com/wofr06/lesspipe/releases/tag/v2.06
- https://security.gentoo.org/glsa/202211-02
- https://bugs.gentoo.org/865631
- https://github.com/wofr06/lesspipe/releases/tag/v2.06
- https://security.gentoo.org/glsa/202211-02
Get alerted when CVE-2022-44542 or the next vulnerability affects your stack