What’s Vulnerable › Vulnerabilities
CVE-2022-44566: Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-09 · updated 2026-10-24
- Weakness: CWE-400
Description
A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1. When a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service.
Affected products
- Activerecord Project Activerecord: before 6.1.7.1; from 7.0.0 before 7.0.4.1 — fixed in 6.1.7.1, 7.0.4.1
- Rubygems Activerecord: before 6.1.7.1; from 7.0.0 before 7.0.4.1; 1.0.0, 1.1.0, 1.10.0, 1.10.1, 1.11.0, 1.11.1 (+424) — fixed in 6.1.7.1, 7.0.4.1
How to fix
Upgrade to a fixed version: Activerecord Project Activerecord 6.1.7.1, 7.0.4.1; Rubygems Activerecord 6.1.7.1, 7.0.4.1. Check the vendor advisory for mitigations.
References
- https://code.jeremyevans.net/2022-11-01-forcing-sequential-scans-on-postgresql.html
- https://discuss.rubyonrails.org/t/cve-2022-44566-possible-denial-of-service-vulnerability-in-activerecords-postgresql-adapter/82119
- https://code.jeremyevans.net/2022-11-01-forcing-sequential-scans-on-postgresql.html
- https://discuss.rubyonrails.org/t/cve-2022-44566-possible-denial-of-service-vulnerability-in-activerecords-postgresql-adapter/82119
Get alerted when CVE-2022-44566 or the next vulnerability affects your stack