What’s Vulnerable › Vulnerabilities

CVE-2022-44570: Denial of service via header parsing in Rack

Description

A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.

Affected products

How to fix

Upgrade to a fixed version: rack 2.0.9.2, 2.1.4.2, 2.2.6.1, 3.0.4.1; Rubygems Rack 2.0.9.2, 2.1.4.2, 2.2.6.2, 3.0.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-44570 or the next vulnerability affects your stack