What’s Vulnerable › Vulnerabilities
CVE-2022-44587: WordPress WP 2FA plugin <= 2.6.3 - Sensitive Data Exposure via Log File vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-21 · updated 2026-06-17
- Weakness: CWE-532
Description
Insertion of Sensitive Information into Log File vulnerability in WP 2FA allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects WP 2FA: from n/a through 2.6.3.
Affected products
- Melapress WP 2FA: before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: Melapress WP 2FA 2.6.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-2fa/wordpress-wp-2fa-plugin-2-6-3-sensitive-data-exposure-via-log-file-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-2fa/wordpress-wp-2fa-plugin-2-6-3-sensitive-data-exposure-via-log-file-vulnerability?_s_id=cve
Get alerted when CVE-2022-44587 or the next vulnerability affects your stack