What’s Vulnerable › Vulnerabilities
CVE-2022-4459: WP Show Posts < 1.1.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The WP Show Posts WordPress plugin before 1.1.4 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- WP Show Posts: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: WP Show Posts 1.1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3ef4783b-4e4a-4691-b858-a7fa8dada4ec
- https://wpscan.com/vulnerability/3ef4783b-4e4a-4691-b858-a7fa8dada4ec
Get alerted when CVE-2022-4459 or the next vulnerability affects your stack