What’s Vulnerable › Vulnerabilities
CVE-2022-44621: Apache Kylin: Command injection by Diagnosis Controller
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-30 · updated 2026-06-17
- Weakness: CWE-77
Description
Diagnosis Controller miss parameter validation, so user may attacked by command injection via HTTP Request.
Affected products
- Apache Software Foundation Apache Kylin: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 4.0.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/7ctchj24dofgsj9g1rg1245cms9myb34
- https://lists.apache.org/thread/7ctchj24dofgsj9g1rg1245cms9myb34
Get alerted when CVE-2022-44621 or the next vulnerability affects your stack