What’s Vulnerable › Vulnerabilities
CVE-2022-44635: Apache Fineract allowed an authenticated user to perform remote code execution due to path traversal
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 68.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-29 · updated 2026-06-17
- Weakness: CWE-22
Description
Apache Fineract allowed an authenticated user to perform remote code execution due to a path traversal vulnerability in a file upload component of Apache Fineract, allowing an attacker to run remote code. This issue affects Apache Fineract version 1.8.0 and prior versions. We recommend users to upgrade to 1.8.1.
Affected products
- Apache Software Foundation Apache Fineract: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fineract 1.8.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/11/29/3
- https://lists.apache.org/thread/t8q6fmh3o6yqmy69qtqxppk9yg9wfybg
- http://www.openwall.com/lists/oss-security/2022/11/29/3
- https://lists.apache.org/thread/t8q6fmh3o6yqmy69qtqxppk9yg9wfybg
Get alerted when CVE-2022-44635 or the next vulnerability affects your stack