What’s Vulnerable › Vulnerabilities
CVE-2022-4464: Themify Portfolio Post < 1.2.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
Themify Portfolio Post WordPress plugin before 1.2.1 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks, which could be used against high privileged users such as admin.
Affected products
- Themify Portfolio Post: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Themify Portfolio Post 1.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1d3636c1-976f-4c84-8cca-413e38170d0c
- https://wpscan.com/vulnerability/1d3636c1-976f-4c84-8cca-413e38170d0c
Get alerted when CVE-2022-4464 or the next vulnerability affects your stack