What’s Vulnerable › Vulnerabilities
CVE-2022-44641
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-776
Description
In Linaro Automated Validation Architecture (LAVA) before 2022.11, users with valid credentials can submit crafted XMLRPC requests that cause a recursive XML entity expansion, leading to excessive use of memory on the server and a Denial of Service.
Affected products
- Debian Linux: 10.0, 11.0
- Linaro Lava: before 2022.11 — fixed in 2022.11
How to fix
Upgrade to a fixed version: Linaro Lava 2022.11. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/01/msg00016.html
- https://lists.lavasoftware.org/archives/list/lava-announce%40lists.lavasoftware.org/thread/WHXGQMIZAPW3GCQEXYHC32N2ZAAAIYCY/
- https://www.debian.org/security/2023/dsa-5318
- https://lists.debian.org/debian-lts-announce/2023/01/msg00016.html
- https://lists.lavasoftware.org/archives/list/lava-announce%40lists.lavasoftware.org/thread/WHXGQMIZAPW3GCQEXYHC32N2ZAAAIYCY/
- https://www.debian.org/security/2023/dsa-5318
Get alerted when CVE-2022-44641 or the next vulnerability affects your stack