What’s Vulnerable › Vulnerabilities
CVE-2022-44645: Apache Linkis (incubating): The DatasourceManager module has a serialization attack vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-31 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.
Affected products
- Apache Software Foundation Apache Linkis: through 1.3.0
References
- https://lists.apache.org/thread/zlcfmvt65blqc4n6fxypg6f0ns8fqfz4
- https://lists.apache.org/thread/zlcfmvt65blqc4n6fxypg6f0ns8fqfz4
Get alerted when CVE-2022-44645 or the next vulnerability affects your stack