What’s Vulnerable › Vulnerabilities
CVE-2022-4466: WordPress Infinite Scroll - Ajax Load More < 5.6.0.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress Infinite Scroll WordPress plugin before 5.6.0.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load: before 5.6.0.3 — fixed in 5.6.0.3
How to fix
Upgrade to a fixed version: dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load 5.6.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/497d0bf9-b750-4293-9662-1722a74442e2
- https://wpscan.com/vulnerability/497d0bf9-b750-4293-9662-1722a74442e2
Get alerted when CVE-2022-4466 or the next vulnerability affects your stack