What’s Vulnerable › Vulnerabilities
CVE-2022-4467: Search & Filter < 1.2.16 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Search & Filter WordPress plugin before 1.2.16 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin.
Affected products
- Search & Filter: before 1.2.16 — fixed in 1.2.16
How to fix
Upgrade to a fixed version: Search & Filter 1.2.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/54168861-c0b8-4de6-a9af-0ad5c20b4a45
- https://wpscan.com/vulnerability/54168861-c0b8-4de6-a9af-0ad5c20b4a45
Get alerted when CVE-2022-4467 or the next vulnerability affects your stack