What’s Vulnerable › Vulnerabilities
CVE-2022-4468: WP Recipe Maker < 8.6.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-09 · updated 2026-06-17
Description
The WP Recipe Maker WordPress plugin before 8.6.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin.
Affected products
- brechtvds WP Recipe Maker: before 8.6.1 — fixed in 8.6.1
How to fix
Upgrade to a fixed version: brechtvds WP Recipe Maker 8.6.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a3bf24af-417e-4ca2-886c-bb36bb2d952b
- https://wpscan.com/vulnerability/a3bf24af-417e-4ca2-886c-bb36bb2d952b
Get alerted when CVE-2022-4468 or the next vulnerability affects your stack