What’s Vulnerable › Vulnerabilities
CVE-2022-4469: Simple Membership < 4.2.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Simple Membership WordPress plugin before 4.2.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin.
Affected products
- Simple Membership: before 4.2.2 — fixed in 4.2.2
How to fix
Upgrade to a fixed version: Simple Membership 4.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b195c373-1db9-4fd7-98d0-0860dacd189e
- https://wpscan.com/vulnerability/b195c373-1db9-4fd7-98d0-0860dacd189e
Get alerted when CVE-2022-4469 or the next vulnerability affects your stack