What’s Vulnerable › Vulnerabilities
CVE-2022-4470: Widgets for Google Reviews < 9.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The Widgets for Google Reviews WordPress plugin before 9.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Widgets for Google Reviews: before 9.8 — fixed in 9.8
How to fix
Upgrade to a fixed version: Widgets for Google Reviews 9.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7c4e51b3-87ef-4afc-ab53-9a9bbdcfc9d7
- https://wpscan.com/vulnerability/7c4e51b3-87ef-4afc-ab53-9a9bbdcfc9d7
Get alerted when CVE-2022-4470 or the next vulnerability affects your stack