What’s Vulnerable › Vulnerabilities
CVE-2022-4472: Simple Sitemap < 3.5.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The Simple Sitemap WordPress plugin before 3.5.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Simple Sitemap: before 3.5.8 — fixed in 3.5.8
How to fix
Upgrade to a fixed version: Simple Sitemap 3.5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2b685a12-2ca3-42dd-84fe-4a463a082c2a
- https://wpscan.com/vulnerability/2b685a12-2ca3-42dd-84fe-4a463a082c2a
Get alerted when CVE-2022-4472 or the next vulnerability affects your stack