What’s Vulnerable › Vulnerabilities
CVE-2022-44729: Apache XML Graphics Batik: Information disclosure vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-22 · updated 2026-10-08
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16. On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.
Affected products
- Apache Xml Graphics Batik: from 1.0 through 1.16
- Debian Linux: 10.0
References
- http://www.openwall.com/lists/oss-security/2023/08/22/2
- http://www.openwall.com/lists/oss-security/2023/08/22/4
- https://lists.apache.org/thread/hco2nw1typoorz33qzs0fcdx0ws6d6j2
- https://lists.debian.org/debian-lts-announce/2023/10/msg00021.html
- https://security.gentoo.org/glsa/202401-11
- https://xmlgraphics.apache.org/security.html
- http://www.openwall.com/lists/oss-security/2023/08/22/2
- http://www.openwall.com/lists/oss-security/2023/08/22/4
- https://lists.apache.org/thread/hco2nw1typoorz33qzs0fcdx0ws6d6j2
- https://lists.debian.org/debian-lts-announce/2023/10/msg00021.html
- https://security.gentoo.org/glsa/202401-11
- https://xmlgraphics.apache.org/security.html
Get alerted when CVE-2022-44729 or the next vulnerability affects your stack