What’s Vulnerable › Vulnerabilities
CVE-2022-4475: Collapse-O-Matic < 1.8.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Collapse-O-Matic WordPress plugin before 1.8.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin.
Affected products
- Collapse-O-Matic: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: Collapse-O-Matic 1.8.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3b5c377c-3148-4373-996c-89851d5e39e5
- https://wpscan.com/vulnerability/3b5c377c-3148-4373-996c-89851d5e39e5
Get alerted when CVE-2022-4475 or the next vulnerability affects your stack