What’s Vulnerable › Vulnerabilities
CVE-2022-44759: HCL Leap is affected by Cross-site scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper sanitization of SVG files in HCL Leap allows client-side script injection in deployed applications.
Affected products
- HCL Software HCL Leap: from 9.0 before 9.3.1 — fixed in 9.3.1
How to fix
Upgrade to a fixed version: HCL Software HCL Leap 9.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-44759 or the next vulnerability affects your stack