What’s Vulnerable › Vulnerabilities
CVE-2022-4477: Smash Balloon Social Post Feed < 4.1.6 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Smash Balloon Social Post Feed WordPress plugin before 4.1.6 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks against logged-in admins.
Affected products
- Smash Balloon Social Post Feed: before 4.1.6 — fixed in 4.1.6
How to fix
Upgrade to a fixed version: Smash Balloon Social Post Feed 4.1.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c32a4c58-9f2b-4afa-9a21-4b4a5c4c4c41
- https://wpscan.com/vulnerability/c32a4c58-9f2b-4afa-9a21-4b4a5c4c4c41
Get alerted when CVE-2022-4477 or the next vulnerability affects your stack